[spip-dev] jQuery UI 1.11

From : brunobergot@... , the 27th June 2014 10:29

Hop, jQuery UI 1.11 est dispo : http://blog.jqueryui.com/2014/06/jquery-ui-1-11-0/ J'allais l'intégrer au trunk, mais ils ont changé la manière de  distribuer les fichiers. D'un côté j'ai un pack avec un fichier  jquery-ui.js sans les js de chaque module, et dans le pack de dev qui  contient chaque module dans un fichier, les scripts ne sont plus  prefixés par jquery.ui Deux possibilités : 1) on switch sans préfixe comme eux, mais du coup on génère petite  incompatibilité pour les plugins qui appellent les scripts directement  sans passer par le pipeline 2) on les préfixe à la main à chaque maj (un peu relou) À noter qu'il n'y aurait que 3 appels directs à corriger dans le core : http://core.spip.org/projects/spip/repository/entry/spip/prive/formulaires/dateur/jquery.dateur.js.html#L4 Autre point, je remarque que les sélecteurs génériques du core utilisent  une version 1.8 de jQuery UI ici : http://core.spip.org/projects/spip/repository/entry/spip/prive/formulaires/selecteur/generique.html#L68 http://core.spip.org/projects/spip/repository/entry/spip/prive/formulaires/selecteur/rubriques.html#L31 Quelqu'un se souvient quelle en est la raison ? Ne pourrait-on pas  brancher les sélecteurs sur la version de jQuery UI embarquée dans le  plugin-dist ? Au plaisir de vous lire :) ++ b_b